developer oracle 10g

Estado
Cerrado para nuevas respuestas.
M

moses

Guest
No corren los forms,.,.
Hola en el developer, inicio el form builder y el oc4j (listener) pero con nada puedo correr los formularios, ya busque foros y ya hice todo lo que me dicen.
- aumentar una variable al sistema = orcl
- iniciar en distinto orden oc4j y después form builder o al reves
- instalar el java initiator
- intentar con mozilla o con iexplorer7
uso el vista e instale el 10gr2 para vista y el developer 101202
ayuda por favor.
 
F

falconhorse28

Guest
sale algún error o simplemente no muestra nada?.

Saludos.
 
M

moses

Guest
explicare lo que hago, ejecuto sql y después ejecuto mi archivo para crear mis tablas.
ejecuto el oc4j instance, para iniciar el listener abro el forms builder..
con el asistente de bloque de datos creo un lienzo con una tabla mia del sql..
se crea el lienzo con la tabla y simplemente le doy clik a rum form. y abre el iexplorer 7 (que es el que tengo) se tarda cargando y al después de un momento dice que hay un error y el iexplorer debe cerrarse, y busca solucion en linea, pero ahí es donde termina todo,..
si cambio a que ejecute con firefox-mozilla.. abre una ventana de oracle y me da el erros siguiente..
ora-12560: tns error del adaptador de protocolo...
y es todo.. en ocasiones el numero de error cambia pero hay se queda,..
Si le dot aceptar me abre una ventanita para conectar nuevamente a la base, escribo el usuario y la contraseña y doy click a aceptar y vuelva a aparecer el mismo error y de hay no avanza..
porfa ayuda y gracias por atenderme..
 
F

falconhorse28

Guest
revisa el tnsnames.ora, puede ser que ahí este mal configurado.

al momento de ingresar la contraseña y el usuario no debería aparecer ningún error ORA-xxxxxx.

Prueba con aquello.

Saludos.
 
M

moses

Guest
yo lo veo bien.. aquí lo pego para que vean es el archivo tnsnames.ora.. la base global es orcl
Código:
# tnsnames.ora Network Configuration File: C:\DevSuiteHome_1\network\admin\tnsnames.ora

# Generated by Oracle configuration tools.

ORCL =

  (DESCRIPTION =

    (ADDRESS_LIST =

      (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

    )

    (CONNECT_DATA =

      (SERVICE_NAME = orcl)

    )

  )

EXTPROC_CONNECTION_DATA =

  (DESCRIPTION =

    (ADDRESS_LIST =

      (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

    )

    (CONNECT_DATA =

      (SERVICE_NAME = ORCL)

    )

  )
hice algo mas... cuando intente en la ventanita que aparece para conectar nuevamente,.. me da el error de que no existe ningún listener....
que puede ser? para que se ejecuten los formularios..?
 
F

falconhorse28

Guest
si te sale el error en el listener, es porque no configuraste bien tu base.

Prueba con lo siguiente, entra a tu base por sqlplus, nombre usuario y contraseña y nombre del tnsnames en tu caso sería orcl.

Si te conecta, entra a tus forms y conectate a la base poniendo los mismos campos.

saludos.
 
M

moses

Guest
en el sql, escribo el usuario la contraseña y abajo la base, y al aceptar me manda este error y vuelve a abrir la ventana para dar los datos otra vez:
ERROR:
ORA-12541: TNS:no hay ningún listener
si dejo ese espacio en blanco, se conecta bien .. normal..
 
Estado
Cerrado para nuevas respuestas.
Arriba Pie