Otra vez: no puedo grabar sonidos

Estado
Cerrado para nuevas respuestas.

Turson

Miembro
Miembro
Saludo foreros. Sucede que al intentar grabar sonido desde mi PC, la herramienta Control de Grabación o algúna otra que utilice, sólo graban un archivo sin audio algúno, tampoco generan imagen de ondas captadas durante el proceso de la grabación.

Digo "Otra vez" en mi título, debido a que en anterior oportunidad toqué ese tema en el foro. Hago la salvedad de que no me fue posible dar seguimiento a esos mensajes por ya estar cerrados.

El driver de audio que utilizo, instalado desde el CD de Utilidades, es el "Avance AC97 Audio", también conocido como tarjeta de sonido: "VIA AC'97 Audio Controller".

Mi PlacaBase es una Biostar M7VKQ (3 PCI, 1 AMR, 2 DIMM, Audio, Video).

Utilizo SO Windows XP Profesional SP2.

En anterior oportunidad yo solucioné este inconveniente por medio de Restauración del equipo a un estado anterior, ya que no me sirvieron los drivers que me sugirieron

En otro tema, aún más antiguo, también escribí (aunque no lo recuerdo). El caso, es que el miembro Lestat me envió un enlace que tendría un archivo de registro para reparar el servicio de audio de windows; sin embargo, ya dicho enlace no está disponible.

Me interesaría conocer a qué archivo se refería Lestat.

PD: Hace como 1 mes y medio se le hizo formateo a mi Disco Duro con Windows XP SP2 Prof., no he instalado muchos programas, no he modificado el registro, salvo por el truco de elegir la cant. de botones similares que quiero ver en barra de tareas.

Lo que me preocupa es una limpieza de archivos obsoletos que hice a través del CCleaner hace algúnos días, no sé si haya generado el inconveniente que he reseñado.

Esta vez no cuento con algún punto de restauración anterior por haberlo desactivado hace poco. :confused:

Agradezco su ayuda.
 

Kbite

Aprender y compartir
Administrador
Hola Turson.

He rebuscado un poco ya que el enlace que dejó Lestat está roto pero lo he encontrado el audiosrv.reg:

Archivo para reparar el servicio "Audio de Windows

Código:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AudioSrv]
"DependOnService"=hex(7):50,00,6c,00,75,00,67,00,50,00,6c,00,61,00,79,00,00,00,\
* 52,00,70,00,63,00,53,00,73,00,00,00,00,00
"Description"="Administra dispositivos de audio para programas basados en Windows. Si se detiene este servicio, los dispositivos de audio y efectos no funcionarán correctamente. Si se deshabilita este servicio, cualquier servicio que dependa explícitamente de él tendrá un error al iniciar."
"DisplayName"="Audio de Windows"
"ErrorControl"=dword:00000001
"Group"="AudioGroup"
"ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
* 74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
* 00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\
* 6b,00,20,00,6e,00,65,00,74,00,73,00,76,00,63,00,73,00,00,00
"ObjectName"="LocalSystem"
"Start"=dword:00000002
"Type"=dword:00000020

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AudioSrv\Parameters]
"ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\
* 00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
* 61,00,75,00,64,00,69,00,6f,00,73,00,72,00,76,00,2e,00,64,00,6c,00,6c,00,00,\
* 00
"ServiceDllUnloadOnStop"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AudioSrv\Enum]
"0"="Root\\LEGACY_AUDIOSRV\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001

Copialo en el bloc de notas y guardalo cómo audio.reg, seguidamente ejecutalo.

La limpieza que hiciste con CCleaner no creo que tenga nada que ver ya que es un programa muy fiable y respetuoso con lo que no debe tocar. Pero tienes, ante la duda, la posibilidad de restaurar esos archivos a su lugar utilizando la copia de seguridad que sugiere el programa, si la hiciste retorna esos archivos a su lugar, tiempo tendrás de volver a correr el CCleaner.

Y al margen de todo lo anterior deberíamos tener, por ser de gran utilidad, la "Restauración del sistema" activada para resolver problemas puntuales

Saludos.
 

Turson

Miembro
Miembro
He ejecutado audiosrv.reg, y me dice que ingresó la información al registro. Reinicié, y noto que el suceso continúa, no puedo grabar sonidos emitidos en mi PC. He probado con la Grabadora de Sonidos de Windows y la aplicación AvRack, pero ambas graban en blanco. :-¿ , de seguro que el StepVoice también arroja lo mismo, y etc.

Hago la salvedad, que si se puede reproducir audio, pero no grabarlo.

El CCleaner no me generó opción de guardar un backup antes de borrar los archivos obsoletos, este programa sólo pregunta si estoy seguro de borrar lo hallado. Donde sí da opción de backup es en sus limpiezas del registro.

No tenía activa la Restauración del Sistema, por seguir los consejos que describen en forospyware.com :(, en donde el desactivarlo es uno de los pasos para efectuar los escaneos de la PC apropiadamente.

En fín, si que me parece extraño, dudo que yo haya cometido algúna variación del sistema, tal vez el asunto se deba a algúnos cuelgues de mi Sistema Operativo, seguramente por fallos en el Procesador. Algo que ya he reseñado en otro post (foro de Hardware), pero no estoy seguro si esta inoperancia de la Grabación, se deba a ello.
 
Estado
Cerrado para nuevas respuestas.
Arriba Pie