Problemas de directX con warcraft 3+ expansion

Estado
Cerrado para nuevas respuestas.
Software
Juegos

LegionXXI

Nuevo Miembro
Miembro
Buenas, soy nuevo en el juego aunque ya he jugado. Mi problema consiste en que al iniciar el juego me dice que necesito tener una versión 8.1 o superior instalada pero yo tengo la 10.0 y no se que hacer. Ademas me pide ahora también que inserte el juego pero al insertarlo me lo sigue diciendo.

Por favor ayudenme que llevo hace tiempo con este problema.

Gracias.
 

RedPhoenix

Super Saiyajin
Super Moderador
Hola LegionXXI y bienvenido al foro.

En primer lugar reinstala el juego y luego además debes de instalar la actualizacion del juego (update). Luego de actualizar el juego, debérás buscar un crack NoCD para la respectiva versión y una vez hecho esto, procedes a instalar la expansión Frozen Throne.

El juego es compatible con Windows Vista pero deberás ejecutar el juego con Modo de Compatibilidad para Windows XP y con Privilegios de Administrador.

Para ello debes hacer click derecho en el icono del escritorio, vas a Propiedades > Compatibilidad y luego en la ficha Modo de Compatibilidad tildas la casilla Ejecutar este Programa en Modo de Compatibilidad Para: y eliges Windows XP. Luego vas hasta la ficha Nivel de Privilegio y una vez alli tildas la opción Ejecutar este Programa como Administrador.

Un saludo.
 

LegionXXI

Nuevo Miembro
Miembro
Gracias por contestar pero ¿como se donde descargarme un crack No CD? Mi juego es original y nunca he sabido como descargar un crack porque nunca me ha hecho falta. Gracias.
 

RedPhoenix

Super Saiyajin
Super Moderador
Disculpa, olvide mencionar que el crack NoCD solo era necesario si tu copia era pirata, pero viendo que posees el juego original está claro que no es necesario.
En ese caso, solo debes actualizar Reign of Chaos a la ultima versión, luego instálas la expansión The Frozen Throne y la actualizas con el Parche 1.22a que lo descargas desde Aquí ( http://ftp.blizzard.com/pub/war3/patches/PC/War3ROC_122a_Castellano.exe). Una vez hecho esto prueba ejecutar el juego en modo de compatibilidad como lo mencioné previamente.
Intenta de esa manera y nos cuentas. Suerte.
Un saludo.
 

LegionXXI

Nuevo Miembro
Miembro
No me ha funcionado. He intentado instalar el parche y ponerlo en la compatibilidad que me has dicho pero sigue poniendo lo mismo de siempre. No se que hacer y no creo que el disco este mal porque antes me funcionaba sin problemas. Por favor dame algúna idea nueva porque yo no tengo ni idea de que hacer. Gracias.

Por cierto, no se por que no he podido descargarme el parche de la expansion de donde me dijiste porque me dice que no es posible completar la actualizacion.

Gracias.
 

RedPhoenix

Super Saiyajin
Super Moderador
Los parches que dejé en los enlaces son los oficiales de la web de Blizzard, y son las versiones para Warcraft III en Español, no veo otro problema que sea que tengas el juego en Inglés y por esto no puedes completar la actualización. De tener el juego en Inglés deberás instalar los parches correspondientes al idioma, que los puedes hallar en el siguiente enlace:
http://eu.blizzard.com/support/article.xml?articleId=22736

Respecto al disco, me parece extraño, si es original debería funcionar y más si dices que se halla en buen estado. En todo caso intenta poner el juego en modo de compatibilidad con Windows 98/2000, y si te pide el disco prueba con el de Reign of Chaos, que por lo que he leído también sirve para poder jugar la expansión.

En caso de actualizarlo como se debe y aún en modo de compatibilidad continúa pidiéndote el CD, no se me ocurre que te puede estar sucediendo, por lo tanto también espera más comentarios respecto al tema. xDD

Un saludo.
 

LegionXXI

Nuevo Miembro
Miembro
No me ha funcionado pero gracias por tu ayuda. Por cierto mi juego no es en ingles ya que lo he instalado en mi otro ordenador y es en español. Me has ayudado con algúnas cosas así que te lo agradezco. Llevare el ordenador a una tienda a ver si me dicen que le pasa. Hasta siempre. o_O o_O
 
Estado
Cerrado para nuevas respuestas.
Arriba Pie