VLAN

Estado
Cerrado para nuevas respuestas.

poderoxo

Nuevo Miembro
Miembro
hola!! bueno aquí teniendo una dudanga.... resulta que nos pidieron que hagamos una topologia, bueno es algo dudosa les explico a cortas..

Tenemos 6 pc's y por lo tanto 3 VLAN (cada VLAN 2 pc).

PC1= VLAN1

PC2= VLAN2

PC3= VLAN3

PC4= VLAN1

PC5= VLAN2

PC6= VLAN3

hasta ahi bien, ahora como podran ver, las pc 1,2,3 están en un sector, donde se encuentran conectados a un Switch (de cisco), lo mismo pasa en el otro lado, ahora estos 2 Switches Cisco se encuentra conectados a un router....

Como el router puede enrutar a las VLAN, esta bien, ahora mi pregunta es:

como es que se puede configurar varias VLAN en un mismo switch(los comandos en switch cisco) , y de ser asi, a cada VLAN se le asigna una IP, ahora a cada VLAN se le asignaria una IP diferente? de ahi si es que se le asignara, entonces la FastEthernet del Router, con cual ip le pongo? claramente esta que le configuro un ip default-gateway al switch.

Gracias..!!

si no comprendieron la topologia bueno respondan.... (si es que se encuentra una señal de vida... )
 

GeeK

Ex-Mod
Miembro
poderoxo dijo:
(si es que se encuentra una señal de vida... )
Respeta :rolleyes:

Jajaja

Mira estas bien en algúnas cosas en otras no tanto...

Lo que pasa es que tienes demasiadas dudas y todas revueltas...

Mira

Lo primero debes de configurar las vlans en cada switch.

Podes tener tantas vlans como puertos tenga tu switch.

Ahora lo podes hacer de modo excec o en Vlan database.

Como no me acuerdo de todos los comandos lo vamos a hacer en vlan database

vlan database

vlan (numero vlan) (nombre) EJM vlan 10 ventas

Y así consecutivamente para todas las que queras.

exit

Lo siguiente es agregar los puertos a las vlans, se ha hace asi:

Desde modo config

interface fastethernet 0/1

switchport access vlan 10 <<<<< Este es el numero de la vlan

Y así para cada Switch

De alli no es que tengas que asignarle una ip a la vlan.

Es mas creo que ni se soporta en switches viejos.

Ahora lo siguiente, es decidir como vas a hacer el enrutamiento intervlan.

Si el router tiene muchos puertos entonces podes conectar una a cada puerto correspondiente de vlan y luego hacer el enrutamiento en el router.

Si no tienes muchos entonces te toca hacer trunking

Osea que un solo puerto de switch esta conectado al Router

Selecciona en puerto de switch y haces lo siguiente.

interface fast 0/4 <<< numero del puerto que queres

switchport mode trunk

switchport trunk encapsulation dot1q

Ojo en la ultima linea, la encapsulacion puede ser dot1q que es el estandar y ISL

Algunos equipos solo soportan una de las dos

Haces lo mismo

en el puerto del router y fin

Cualquier cosa me decis

Saludos
 

poderoxo

Nuevo Miembro
Miembro
GeeK dijo:
en primer lugar quiero disculparme si alguien se sintio ofendido, lo escribi sin intencion de ofender, solo era gracia...

pues fijándome y leyendo un poco mas sobre las VLAN, pues resulta facil, a lo que tu dices esta bien, hoy mismo en la mañana estaba probando como crearlas, leyendo mas y mas resulto ser facil.

bueno algo que no me sabia es que era eso del ''trunk'', eso también del ''ISL'', pues estaba en el packet tracer 4.1 (Actualizo!! uff ya era hora :confused: ) y estaba probando y pues me salio bien, ahora hace falta hacer la topologia real (es grande pero voy a ver si resulta).

Como decía Geek(mis respetos, hay que bajarse el sombrero si es que pasa por un tema ) eso del que switch puede usar solo un cable para conectarse por el router, o también puede usar para cada vlan un cable diferente, resulta que estaba probando y lo hice con solo cable, pues recien me sorprendi que al router mismo, entrando a:

Router(config)#interface fastEthernet 0/0

Router(config-if)#interface fastethernet 0/0.1

Router(config-subif)#encapsulation dot1Q 10 esta era el numero de mi vlan

pues se podia entrar a una subinterface que tenia en la interfaz....y así lo hice

en el mismo switch lo configure asi:

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

pues solamente le puse y me funko... hasta ahorita no hay duda, mañana voy a hacerlo la topologia...

bueno una duda me quedo picando...

¿ DOT1Q ? :confused:

¿ ISL ? :confused:

¿una subinterfaz dentro de una interfaz del router ? :confused:

Ojo, las configuraciones las hice, sin ''tipear'' nada de ''trunk'' solo las cosas que están ahi escritas....

Gracias

puede ser que me haiga equivocado, pues no recuerdo bien lo que hice en la mañana, mañana 12 julio voy a sacar mis de dudas..
 

GeeK

Ex-Mod
Miembro
poderoxo dijo:
en primer lugar quiero disculparme si alguien se sintio ofendido, lo escribi sin intencion de ofender, solo era gracia...
Che pibe solo estaba bromeando


poderoxo dijo:
Geek(mis respetos, hay que bajarse el sombrero si es que pasa por un tema )
Creo que voy a ponerle chincheta a este tema para que todos los miren jajaja



poderoxo dijo:
bueno una duda me quedo picando...

¿ DOT1Q ? :confused:

¿ ISL ? :confused:

¿una subinterfaz dentro de una interfaz del router ? :confused:
Dot1q y ISL son los protocolos de etiquetado en Vlans...

Osea es la manera de distinguir el trafico de una vlan del de otra...

Ojo te decía que Dot1q es el estandar, eso significa que podes meter switches de diferentes marcas en la topologia... ISL solo funka con Cisco nah mas. :(

poderoxo dijo:
Ojo, las configuraciones las hice, sin ''tipear'' nada de ''trunk'' solo las cosas que están ahi escritas....
mmmm

Seria de verificarlo pibe

Cualquier cosa ya sabes

Saludos
 

poderoxo

Nuevo Miembro
Miembro
bueno ''GeeK'' y para cualquiera que sepa.. aquí estamos de nuevo...

prendi a subnetear un poco, pero por lo que veo esta bien sino corregirme...

166.112.0.0 necesito 20 subredes

subredes creadas son 166.112.0.0 --- 166.112.248.0

las primeras 20 subredes voy a utilizarlas...

ahora el problema con las vlan ya no es tanto

mira te dejo la imagen para que chequees...



bueno esa es la imagen, están configuradas los switches, tanto como los routers.

empezando a resumir...

Dir clase B. 166.112.0.0 /16

lo dividi en 20 subredes... por tanto quedaria asi...

166.112.0.0 --- 166.112.160.0 (estas son las subredes que voy a utilizar..)

Mascara de Subred 255.255.248.0 o también /21

ahora están asignadas asi..

para el router1 usa las subredes 166.112.0.0 --- 166.112.24.0

para el router2 usa las subredes 166.112.32.0 --- 166.112.56.0

para el router3 usa las subredes 166.112.64.0 --- 166.112.88.0

ojo cada router tiene 3 VLAN, ahora las cada VLAN DE COLOR tiene que tener conectividad (osea VLAN ROJO del router1 con VLAN ROJO del router2)

todo bien? espero que este entendible :confused: ...

sigue...la VLAN ROJO del router1 hace ping entre si...o sea todo bien, ok perfecto ninguna falla, lo mismo pasa con cada vlan de los tres routers... (menos el router4)

entendible? :confused:

ahora mira cuando ejecuto un protocolo de enrutamiento...en este caso ejecute RIPv2 (el mas fácil , me pidieron OSPF), a cada router le puse la network 166.112.0.0 (porque esta es la madre de todas las subredes, y si pongo una subred ejemplo 166.112.32.0 me la acepta como 166.112.0.0 eso esta bien)

decia que ejecuto el protocolo de enrutamiento RIPv2

router rip

version 2

network 166.112.0.0

ahora cuando quiero hacer un ping, no llega el ping, sino que el ping ''muere'' en el mismo router...

¿porque? :confused:

los switches están configurados correctamente, el router central esta configurado correctamente.... el ping muere en el mismo router, ni siquiera sale...

se recibe todo tipo de ayuda :confused: :confused:
 

poderoxo

Nuevo Miembro
Miembro
bueno resulta ni mas ni menos, que las conexiones seriales estaban puestas incorrectamentes....

el Router Central su serial 1/2 debería de estar conectado con el Router 1 pero estaba conectado con el Router 3 , y pues sucede lo mismo con los otros.... ni mas ni menos... van a disculpar si es que les meti problemas o les quite su tiempo... ;) ;)

ahora hace ping entre las vlan

Gracias..
 

poderoxo

Nuevo Miembro
Miembro
bueno ahora este es otro problema...

como configuro esta parte, como configuro en los switches....para que el server de color (cualquier color ) haga un ping a al router4, ahora si me fije bien, esta configurado bien, los cables esta vez si están puestos correctamente, el router configurado con subinterfaces... dado que los switches tiene STP (Spanning Tree Protocol) configuro el SWITCH STP 1 como el switch raiz, ahora como hago para que hagan ping?




nose si tendre que configurar el Switch STP 2 y el Switch STP 3... :confused: :confused:
 

GeeK

Ex-Mod
Miembro
Che

Poco he usado el PacketTracert pero lo que me llama la atencion

Es que entre el Sw1 y el Router 5 tienes los links inoperativos...

Verificaste que ambos estén a la misma velocidad...

Osea te lo digo porque aparece un punto rojo.

Entra a la configuración del Sw1 y haz desde alli un ping al Router 5 aver si lo alcanzas.

Saludos o_O
 

poderoxo

Nuevo Miembro
Miembro
GeeK dijo:
Es que entre el Sw1 y el Router 5 tienes los links inoperativos..
Van a disculpar, es que esa imagen la recorte de la primera foto :eek: esta es la foto verdadera, el R4 reconoce todas las redes, a excepcion de los servidores.

Esta configurado bien el Switch STP 1 con la VLAN 1 con ip correcta, ahi esta una imagen del paquete enviado, y como podran ver esta bien.

esta es la foto actualizada y la del problema



Me pregunto, supuestamente el Switch STP 1, tiene modificado el trunk en fa0/10 (con el que se conecta al router) y tiene dos interfaces conectadas a los otros switches.

Se puede asignar una VLAN por interface, de modo que tengo 2 interfaces conectadas y solamente puedo asignar 2 VLan's, ahi estaría dejando sin conectividad a una VLAN.

entonces como resuelvo este lio

me deje explicar bien? :confused:

este es un nuevo packet tracer, es la versión 4.1!!! (la anterior era 4.01) bueno de poco a poco se progresa, trae nuevas mejoras... como telnet y demas cosas, voy a tratar de subirlos para que lo bajen y practiquen...
 

GeeK

Ex-Mod
Miembro
Hola. Si no te entiendo mal, dices que tienes un puerto de Switch por cada Vlan?

Lo que tienes que hacer es igual que con el router, configurar los puertos de Switch que están conectados entre ellos mismos como Puertos de Trunk, así no tienes necesidad de gastar un puerto por Vlan sino que unicamente haces una conexion...

Saludos o_O
 

poderoxo

Nuevo Miembro
Miembro
bueno gracias por responder y por tomarte el tiempo de leer y ayudarme...

resulta que solamente hice un ''trunk'' entre los swithces... a cada uno le hice un trunk por el cable con que se conectaba al otro switch.

despues de eso, le asigne la prioridad a SWITCH STP 1 (para que todos los swtiches vean que es el puente raiz) y todos manden sus actualizaciones hacia ese switch, ademas a cada switch le asigne una ip a la vlan 1, todas los switches llevaban la misma red.

Bueno ahora puede haber conectividad entre todos los host.

Gracias por tomarse su tiempo en entender, ayudar y responder este post.

Problema resuelto o_O o_O
 
Estado
Cerrado para nuevas respuestas.
Buscar...
Arriba Pie